Preference Activity 的兼容性

Android 3.0(API 11)之前是不支持Preference FragmentPreference Header的,为了能提供给所有用户一个良好的用户体验,就需要对 Android 3.0 之前和之后的版本分开处理。简要处理如下:

Class c = Build.VERSION.SDK_INT < Build.VERSION_CODES_HONEYCOMB ? 
          MyPreferenceActivity.class : MyFragmentPreferenceActivity.class;

Intent i = new Intent(this, c);

startActivityForResult(i, 1); //here: aurument 1 can be some value you needed